1. Home
  2. GetFund – A Professional Laravel Crowdfunding Platform
  3. Upgrade Guide

Upgrade Guide

GetFund – A Professional Laravel Crowdfunding Platform is a PHP crowd funding script built with Laravel, that allows you to raise funds from donor in a seamless way like Kickstarter or Indiegogo

Download latest version using your account from CodeCanyon if you already purchased, if not, purchase it from GetFund – A Professional Laravel Crowdfunding Platform

Upgrading To Version 2.3.4 From 2.1 or later

Getfund version 2.3.4 comes with a security update with performance improvement, to update, please replace the files below to from newly downloaded source.

M: app/Http/Controllers/CampaignsController.php
M: app/Http/Controllers/CategoriesController.php
M: app/Providers/AppServiceProvider.php
M: app/helpers.php
M: resources/views/admin/edit_campaign.blade.php
M: resources/views/admin/edit_page.blade.php
M: resources/views/admin/page_create.blade.php
M: resources/views/admin/start_campaign.blade.php
M: resources/views/payment.blade.php

Upgrading To Version 2.1 From 1.9

Version 2.0 is not updated much more if you update to GetFund version 2.1, it will also cover 2.0. GetFund 2.1 comes with some bug fix, please replace below file from the latest version package to your server to get 2.1

M public/assets/css/style.css
M resources/views/home.blade.php
M resources/views/layouts/footer.blade.php

Upgrading To Version 1.9 From 1.7

We’ve skipped version 1.8 due to a minor change and affected only at one file, Please find following files to new version you’ve already downloaded, replace and/or add them

M app/Campaign.php
M app/Http/Controllers/CampaignsController.php
M app/Http/Controllers/CategoriesController.php
M app/Http/Controllers/PaymentController.php
M app/Http/Controllers/SettingsController.php
M app/Http/Controllers/UserController.php
M app/Http/Middleware/VerifyCsrfToken.php
M app/helpers.php
M database/migrations/2017_04_01_115454_create_payments_table.php
M resources/views/campaign_faqs.blade.php
M resources/views/campaign_single.blade.php
M resources/views/campaign_update.blade.php
M resources/views/layouts/header.blade.php
M resources/views/single_page.blade.php

Don’t forget to use latest database, or your may get errors

You can include only one table from latest database called payments .

 

Upgrading To Version 1.7 From 1.6

Find following files to new version you’ve already downloaded, replace and/or add them

M app/Campaign.php
M app/Http/Controllers/PaymentController.php
M app/Http/Controllers/UserController.php
A app/Withdrawal_preference.php
A app/Withdrawal_request.php
M app/helpers.php
A database/migrations/2017_07_22_154825_create_withdrawal_preference.php
A database/migrations/2017_07_22_184150_create_withdrawal_requests.php
M resources/lang/en/app.php
M resources/views/admin/dashboard.blade.php
M resources/views/admin/edit_campaign.blade.php
M resources/views/admin/general_settings.blade.php
M resources/views/admin/menu.blade.php
M resources/views/admin/payments.blade.php
M resources/views/admin/withdraw.blade.php
A resources/views/admin/withdraw_requests.blade.php
A resources/views/admin/withdrawal_details.blade.php
A resources/views/admin/withdrawal_preference.blade.php
M resources/views/payment.blade.php
M routes/web.php

Don’t forget to use latest database, or your will get errors

You can include only two table from latest database called withdrawal_preferences and withdrawal_requests.

Done, you’ve upgraded to latest version of GetFund php crowdfunding script

Upgrading To Version 1.6 From 1.5

Replace root/resources/views/payment.blade.php with payment.blade.php
replace root/resources/views/admin/edit_campaign.blade.php with edit_campaign.blade.php
replace root/resources/lang/en/app.php with app.php

That’s it, you are now running version GetFund 1.6

Was this article helpful to you? Yes No

How can we help?