Home Forums Themeqx Advanced PhP Laravel Classified ads cms forwarding my website to https secure link

Tagged: ,

  • #598

    srinath
    Participant

    779

    forwarding my website to https secure link

    when I change my url to https I am unable to load my CSS & js assets (Mixed content error). So, i just wanna know how to solve this problem
    https://www.sainikbazaar.com/

Viewing 2 replies - 1 through 2 (of 2 total)
  • #599

    Hi @srinath

    It should be make auto https when load asset file like css, js and others images, seems something wrong with your server, but don’t worry, i am giving you solution

    Go to /root/resources/views/layout/header.blade.php

    find all line start with asset('
    looks like a line below

    asset('assets/css/bootstrap.min.css')

    you need to pass a Boolean true in second parameter, like asset('assets/css/bootstrap.min.css', true)

    also find /root/resources/views/layout/footer.blade.php

    do it same to make https loading js files, add a parameter all of your asset url, like below

    asset('assets/js/vendor/jquery-1.11.2.min.js', true)

    Looks, you are adding only true with a comma just before closing first brackets,

    Your css and js will now serve over https

    Best rgards

    #666

    srinath
    Participant

    Thanks it’s working but the other problem is that my images are loading with HTTP protocol i guess that is why am unable to load my page when i type this in url box (https://sainikbazaar.com/). It’s loading only when i give permission to load scripts from unauthenticated sources in url bar. So, please help me with it.

Viewing 2 replies - 1 through 2 (of 2 total)

Purchase for access

Buy a copy of Themeqx Advanced PhP Laravel Classified ads cms for access to our member center.

Buy